PDA

View Full Version : Winch trouble



simonjk
08-08-2013, 02:17 AM
I have a used winch on my new used jkur. It is a warn 9.5 ti winch. But it seems as it is not getting power. I can manually pull it out but nothing else. I followed the wires and they are connected. The controller has no light on it either when I try to use it. Is it a bad motor, solenoid, or something else. Thanks in advance

Sent from my SCH-I535 using WAYALIFE mobile app

Wizard
08-08-2013, 02:22 AM
Can you hear the winch solenoids clicking when you try and use the controller?

simonjk
08-08-2013, 02:46 AM
I hear nothing. Its like its completely dead

Sent from my SCH-I535 using WAYALIFE mobile app

Wizard
08-08-2013, 07:18 AM
I'd be checking for power on the control side of the solenoids. Is there a fuse or circuit breaker for this control side (should be)?

simonjk
08-08-2013, 07:52 AM
Idk. I haven't broken it apart yet to check. When I get off work, I am going to try taking the covers off to see. Should there be a control box or fuse or something there?

Sent from my SCH-I535 using WAYALIFE mobile app

Wizard
08-08-2013, 08:08 AM
I believe there should be a fuse or circuit breaker on the positive lead to the solenoid control circuit (don't get this confused with the main positive cable leading to the solenoid which feeds the winch motor). Do you have a multiple meter or test light to check for power?

simonjk
08-08-2013, 09:16 AM
yes i do. i can check for power when i get home. so the power coming off the solenoid, check that. and check the main power?

Wizard
08-08-2013, 11:06 AM
Just thinking about this a bit more, the solenoid controls on the 9.5 ti probably won't have a fuse or breaker fitted.

FrankenJeeper
08-08-2013, 12:32 PM
^ winch wizard 😎


2010 JKU Sport
1977 CJ5

Sent from my iPhone using WAYALIFE mobile app

David1tontj
08-08-2013, 01:34 PM
Do you have a friend with a warn winch that you can try their remote?? That is a solid winch that shouldn't have problems, but the remote could be crapping out. My brother had a Ramsey winch with a crappy remote that gave these same symptoms. Good luck