PDA

View Full Version : Need help! Front axle trouble.



matt08jk
08-10-2013, 07:55 PM
Just drove from Fort Bragg to Fort Rucker and towards the end of the trip I noticed a faint metal knock that slowed as the vehicle slowed and sped up as it sped up. I pulled over and saw no contact for the wheels, tires with the body. When I finally arrived at Rucker I found that my right front axle u joint assembly was rubbed silver from hitting the lower portion of the c2. Why would this happen and how deep am I in to fix it??? Thanks for anybody's help!

Rebel JK
08-11-2013, 02:06 AM
Hopefully someone with more jk experience will chime in, but i would think either bad axle bearing or u joint? I would take a big ass screw driver or small bar and put between lower c and u joint and see where the play is at.

Serg5000
08-11-2013, 02:50 AM
Is the u joint cap coming out. Can you provide a picture to help us figure this out.

matt08jk
08-11-2013, 03:25 AM
Is the u joint cap coming out. Can you provide a picture to help us figure this out.

I am new to this so I don't really know. I only had a second to grab a pic but here is a picture of the part of the u joint assembly that is connecting the c.
44050

You can see the silver ring around the u joint where the contact has been made. Thanks for taking a look!

silverbackjk
08-11-2013, 03:29 AM
I am new to this so I don't really know. I only had a second to grab a pic but here is a picture of the part of the u joint assembly that is connecting the c.
44050

You can see the silver ring around the u joint where the contact has been made. Thanks for taking a look!

Looks like a your u joint cap is falling off.


Sent from my iPhone using WAYALIFE mobile app

Serg5000
08-11-2013, 04:03 AM
Easy fix man. Just pop a new u-joint in there.

matt08jk
08-11-2013, 01:27 PM
Thanks everybody. I'm going to get a new u joint and try to install it. As always thanks for all of the quick responses and help. It's the stuff that makes you want to hang around.