PDA

View Full Version : I'm pretty much stupid and can use some help!



TXlineguy
11-12-2015, 01:45 AM
Hey everyone I have a 2015 two door I have the Evo double D pro Long arm kit and well I could use some help with how to get my alignment better. Yes I have read that Basic alignment write up but I'm definitely sharpest tool in the shed and to be honest I have no idea what I'm doing. If anyone's got me pointers I sure appreciate it....173409[ATTACH=CONFIG]

WJCO
11-12-2015, 01:50 AM
Hey everyone I have a 2015 two door I have the Evo double D pro Long arm kit and well I could use some help with how to get my alignment better. Yes I have read that Basic alignment write up but I'm definitely sharpest tool in the shed and to be honest I have no idea what I'm doing. If anyone's got me pointers I sure appreciate it....

Before we get started, what was your original symptom? Or did you just take it to get aligned after the lift?

Tree Frog
11-12-2015, 03:37 AM
Well here goes some of what I know (Or think I know)

Camber is not adjustable on a JK (Solid axle vehicle)
Questions would be how far out of spec is this? If it is way out then a few things to check are for worn damaged ball joints, bent tube, bent C's on the end of the tube.
I would say if it is just a little out, then F. it.

Caster is easily adjusted with your long arms. If the bottom arms are all the way in, then run the fronts out a bit more. I know all rigs are different but my lowers are almost too long all the way in.
A lot of guys have vibration at 6 degrees but it rides nice. I think target spec is 4 degrees.
I have ran mine from 6 and now down to 4 with no vibration at all.

Toe in is also easily adjusted. Had you messed with your tie rod during install? If not and if you have not smacked a rock then it also should be fine.

What problems are you experiencing? Did you get the alignment checked for a reason or was this a preventive measure?
Does anyone have a cop of the factory specs?

TXlineguy
11-12-2015, 04:59 AM
Symptoms are vibration on the driver side my rear view Driver side mirror vibrates pretty good. When I get it up to about 80 to 90 it feels squirrley and all over the place. Front end is completely stock other than coilovers and arms.

Tree Frog
11-12-2015, 03:42 PM
So did you change out your drive shafts?
If so try removing the front and test drive it.
At approximately 6 degrees of castor it could be too much or a shaft may be out of balance.

How is your tire balance?
Try a rotation and see if the vibration moves.

Tree Frog
11-12-2015, 03:44 PM
90 mph ?
Well okay but dang son. HA

WJCO
11-12-2015, 04:04 PM
Symptoms are vibration on the driver side my rear view Driver side mirror vibrates pretty good. When I get it up to about 80 to 90 it feels squirrley and all over the place. Front end is completely stock other than coilovers and arms.

None of these angles on the printout should cause a vibration like you're talking about unless it's a driveline vibration. Typically that won't even cause your mirror to shake. I think you have a tire issue.

Your camber being a little out on the LF could cause some tire wear but not vibration, to correct it, you probably have a worn ball joint or possibly something bent.

As far as your caster, it's a little on the positive side, but that should IMPROVE your handling during your illegal driving habits LOL.

And your toe being out, that's an easy fix. They should have fixed that for you while it was on the alignment machine. It's a lot of effort for the tech to hook up the sensors on the rack and not send you away with a toe set in my opinion. Unless he told you to fix camber/caster first before he would touch the toe.

mudmobeeler
11-12-2015, 04:17 PM
I get it up to about 80 to 90 it feels squirrley and all over the place.

You realize your in a jeep right? Why 80 or 90? I get 75-80 on the highway but 90?

WJCO
11-12-2015, 04:17 PM
You realize your in a jeep right? Why 80 or 90? I get 75-80 on the highway but 90?

He's a stunt man for the next Fast and Furious movie.

TXlineguy
11-13-2015, 06:20 AM
Tomorrow I'm planning on getting a tire rotation and balance and seeing if that helps...... The limits are 85 down here y'all and 75 is just so slow.
Definitely no stuntman I'm not too bright and well I would be the guy that forgot his helmet and dies because of it

jeeeep
11-13-2015, 06:50 AM
Tomorrow I'm planning on getting a tire rotation and balance and seeing if that helps...... The limits are 85 down here y'all and 75 is just so slow.
Definitely no stuntman I'm not too bright and well I would be the guy that forgot his helmet and dies because of it

when the sign says 75-85 that's the minimum here in Texas. When I was traveling for work to Houston and area I had a GC with a hemi I'd set the cruise at 105 and still got passed like I was doing 55!

daverawr
11-13-2015, 06:57 AM
when the sign says 75-85 that's the minimum here in Texas. When I was traveling for work to Houston and area I had a GC with a hemi I'd set the cruise at 105 and still got passed like I was doing 55!

That's Houston for you..... We drive very fast compared to most of the state and other states. Loll. I cruise 85+ in the jeep daily.... My old sports car cruising was 95-100 lol. [emoji23]