PDA

View Full Version : What is this rattling box ?



danford.lau
07-16-2018, 01:12 AM
Can someone tell me what this box is ? Located on the rear and has hoses running to fuel tank .

When I tap on it, it rattles . Can hear the rattle during acceleration.

305918


Sent from my iPhone using WAYALIFE mobile app (http://r.tapatalk.com/byo?rid=73415)

jdofmemi
07-16-2018, 01:19 AM
That is the evap canister.

Has it come loose? It only has one bolt that holds it to the factory guard. Mine broke loose, and that led to it rattling around.

danford.lau
07-16-2018, 01:22 AM
The one bolt underneath the white piece was pretty rusted. Possible that thatís what is rattling .


Sent from my iPhone using WAYALIFE mobile app (http://r.tapatalk.com/byo?rid=73415)

danford.lau
07-17-2018, 03:25 PM
Tightened this 13mm bolt . Evan can still has a slight rattle when tapped but from search sounds like thatís fairly normal . Still canít isolate my rattle upon acceleration . Just hose clamped heat shield on exhaust cross over as well so thatís not it .


Sent from my iPhone using WAYALIFE mobile app (http://r.tapatalk.com/byo?rid=73415)

zimm
07-17-2018, 11:56 PM
Whatever you do, don't pull the fitting off the back. I did, chasing a rattle. Sure it rattles. I also broke it. I jammed it back in but got a CEL. Took to dealer and it was $300 to fix. Not warrantied. They even used some kind of smoke machine through the emissions system to trace the leak, and it was the fitting I broke. I claimed a rock must have done it so I didn't look so stupid.

VeruGE*144
07-18-2018, 02:15 AM
Whatever you do, don't pull the fitting off the back. I did, chasing a rattle. Sure it rattles. I also broke it. I jammed it back in but got a CEL. Took to dealer and it was $300 to fix. Not warrantied. They even used some kind of smoke machine through the emissions system to trace the leak, and it was the fitting I broke. I claimed a rock must have done it so I didn't look so stupid.

Nice one lol, Iíve had few of those.

jdofmemi
07-18-2018, 02:22 AM
Well, you have saved me that problem.

My problem is the EVO skid I bought came in one run too late, after I slipped off my line and hung it in a rock garden. I managed to mash the shit out of the factory shield, and broke the tab the one bolt goes into.

I cut the factory shield away, since it was done anyway, and zip tied the evap to the EVO skid and it is living, for now.

2nd.gunman
07-18-2018, 02:24 AM
Whatever you do, don't pull the fitting off the back. I did, chasing a rattle. Sure it rattles. I also broke it. I jammed it back in but got a CEL. Took to dealer and it was $300 to fix. Not warrantied. They even used some kind of smoke machine through the emissions system to trace the leak, and it was the fitting I broke. I claimed a rock must have done it so I didn't look so stupid.

Yeah I bet they believed that


Sent from my iPhone using WAYALIFE mobile app (http://r.tapatalk.com/byo?rid=73415)