PDA

View Full Version : Leak after aftermarket driveshaft install



TxCoastie
09-05-2019, 08:56 PM
Ill pulled the new driveshaft back off to assess.

Gear oil leaking from the backside of the front diff. under the seal.

I never saw a crush washer after putting the new yoke on.

Any help much appreciated.

334138

Sent from my SM-G892U using WAYALIFE mobile app (http://r.tapatalk.com/byo?rid=73415)

fiend
09-05-2019, 08:57 PM
Pinion seal is leaking.


Sent from my iPhone using WAYALIFE mobile app (http://r.tapatalk.com/byo?rid=73415)

jesse3638
09-05-2019, 09:45 PM
Pinion seal is leaking.


Sent from my iPhone using WAYALIFE mobile app (http://r.tapatalk.com/byo?rid=73415)

I'd second this. So far so good on my Jeep but my old Titan developed the same thing on the rear diff. A typical "Easy" job for me turned into an all day ordeal...haha. I'm not sure how these are but with my truck I measured the rotational torque, pulled the yoke, took a seal puller and got the old one out (Once you start with one of those there is no turning back as it fucks up the old seal bad). Took some different ABS pipe fittings and a hammer to pound the new one in, red lock tighted the pinion nut and torqued it to 160 and began measuring the rotational torque until it was about 5 inch pounds more than what it started as. Worked well and never leaked for the couple years after until I traded it in. Hopefully this is helpful.

TxCoastie
09-05-2019, 09:49 PM
Pinion seal is leaking.


Sent from my iPhone using WAYALIFE mobile app (http://r.tapatalk.com/byo?rid=73415)Thanks!

https://www.quadratec.com/products/52426_1102.htm?gclid=Cj0KCQjw5MLrBRClARIsAPG0WGw7Q OCqG37ZEyFPI5StnjPKU80y8OUAoVT8RlVwqvIMN2vpzmw466U aAqh-EALw_wcB

Right part correct?

Sent from my SM-G892U using WAYALIFE mobile app (http://r.tapatalk.com/byo?rid=73415)

TxCoastie
09-05-2019, 09:53 PM
A typical "Easy" job for me turned into an all day ordeal...haha.

This seems to be my s.o.p.[emoji849]

Sent from my SM-G892U using WAYALIFE mobile app (http://r.tapatalk.com/byo?rid=73415)

fiend
09-05-2019, 09:59 PM
Thanks!

https://www.quadratec.com/products/52426_1102.htm?gclid=Cj0KCQjw5MLrBRClARIsAPG0WGw7Q OCqG37ZEyFPI5StnjPKU80y8OUAoVT8RlVwqvIMN2vpzmw466U aAqh-EALw_wcB

Right part correct?

Sent from my SM-G892U using WAYALIFE mobile app (http://r.tapatalk.com/byo?rid=73415)

Looks like it. I’d order a few pinion nuts too. Theoretically you’re not supposed to reuse them.


Sent from my iPhone using WAYALIFE mobile app (http://r.tapatalk.com/byo?rid=73415)

TxCoastie
09-06-2019, 01:09 AM
Thanks fiend!

Sent from my SM-G892U using WAYALIFE mobile app (http://r.tapatalk.com/byo?rid=73415)

USMC Wrangler
09-06-2019, 02:30 AM
I’ve seen it mentioned here that you can put a little RTV on the lip of the new seal too. Just some insurance.


.................................................. ..............
2013 JKU Sport S, named Spider

http://wayalife.com/showthread.php?26097-I-guess-it-s-the-quot-Super-Stocker-quot-build

WJCO
09-06-2019, 02:35 AM
Where the lip of the seal meets the yoke, use bearing or lithium grease. If that part of the seal isn't damaged, you should be OK. Rtv the outer diameter of the pinion seal (the metal part that touches the pumpkin/housing) and locktite the pinion nut.

TxCoastie
09-06-2019, 08:09 PM
Thanks for all your help.

Wondering why the leak started in the first place[emoji2369]

Sent from my SM-G892U using WAYALIFE mobile app (http://r.tapatalk.com/byo?rid=73415)

fiend
09-06-2019, 08:43 PM
Thanks for all your help.

Wondering why the leak started in the first place[emoji2369]

Sent from my SM-G892U using WAYALIFE mobile app (http://r.tapatalk.com/byo?rid=73415)

Seals leak all the time. The world’s an imperfect place.


Sent from my iPhone using WAYALIFE mobile app (http://r.tapatalk.com/byo?rid=73415)

cpefy3
09-12-2019, 04:31 PM
I'd make sure your new driveshaft is properly balanced. An unbalanced driveshaft will cause pinion seals to fail prematurely. Good luck!!

Attenuator
09-13-2019, 02:54 AM
If you didn't lube the sealing surface of the new yoke when you installed it, you possibly may have damaged the seal causing the leak... I've done it a couple times in my life....oops.

Andy5160
09-13-2019, 03:20 AM
Had the same issue most likely you crashed the sleeve and damaged the seal.
Get it replaced it is super easy. Get the seal pull tool. 334605334606


Sent from my iPad using WAYALIFE mobile app (http://r.tapatalk.com/byo?rid=73415)

TxCoastie
09-16-2019, 03:53 PM
Thanks everyone. I replaced both just cause. Easy job. No more leaky[emoji16]

Sent from my SM-G892U using WAYALIFE mobile app (http://r.tapatalk.com/byo?rid=73415)

Attenuator
09-20-2019, 11:14 PM
Thanks everyone. I replaced both just cause. Easy job. No more leaky[emoji16]

Sent from my SM-G892U using WAYALIFE mobile app (http://r.tapatalk.com/byo?rid=73415)

Glad it worked out!