PDA

View Full Version : Power steering issue



07rub
04-25-2012, 08:15 PM
hey guys,

i'm starting to have problems with my power steering, pump is making noise and i have dead spots when turning, i was wondering if anyone else add this issues and if they found the fix

and i have an 07 jku rubicon

07rub
04-27-2012, 07:46 PM
Really? No one??

2012jkfng702
04-27-2012, 11:06 PM
Sorry brotha, Just got my Jk and haven't experience a power steering issue in any of my other rigs. I would check the project JK site if one of the other guys doesn't get back to you.

Moochie
04-27-2012, 11:22 PM
My pump started making noise and a new pump fixed it. At the time I was on 35" tires and I knew that it would eventually fail.

Hightower
04-28-2012, 07:44 AM
Are you going to look into hydro assist steering? I got my kit laying on the floor waiting on my pro rocks 60 to show up.

07rub
05-01-2012, 05:06 PM
Would be nice to get the hydro assist but pricey and im only running 33' right now so im gona try some lucas this weekend see if it helps if not new pump would be i the future

trewin73
01-21-2013, 05:56 PM
Would be nice to get the hydro assist but pricey and im only running 33' right now so im gona try some lucas this weekend see if it helps if not new pump would be i the future

hey i was just wondering what it was that fixed your problem, i have the same thing going right now. I am also thinking of getting lucas stop leak for steering. i was wondering if this helped or if you went straight to a new pump. i am running a '09 JK Rubi 4 door with 35's. kinda figured it would mess with the pump after i put new rubbers on. if you went with a pump what kind did you get.

thanks.

JeepFan
01-21-2013, 06:13 PM
Not sure about the noise but if you're experiencing dead spots eg. Lack of power steering when turning. Check your steering stabilizer to make sure the push rod moves in and out without sticking or binding. It should have some resistance when pushed in or pulled out but not stick at any point in its travel.