Results 1 to 5 of 5

Thread: 2001 Jeep Wrangler Sport 4.0 liter

  1. #1
    Fresh Catch Creekcrawler's Avatar
    Join Date
    Dec 2016
    Location
    US
    Posts
    4

    2001 Jeep Wrangler Sport 4.0 liter

    When I start my Jeep the oil pressure is normal. After it has warmed up a bit the oil pressure drops some and when u pull up to a stoplight the oil pressure drops to just barley above 0. When you pull up somewhere and shut it off, then when its started back up I have no oil pressure at all and a check gauges light is on and a beeper going off. There is no peaking or knocking noise going on in the engine and it gets a lower than Normal oil pressure reading.
    Anybody had this problem and know a fix for it?

    Sent from my SAMSUNG-SGH-I547 using WAYALIFE mobile app
    Attached Images Attached Images

  2. #2
    Nothing but a Thing Judesign's Avatar
    Join Date
    Mar 2015
    Location
    San antonio
    Posts
    1,121
    Welcome to WAL.

    Could be major like bad main bearings or something easier to fix like a faulty oil pump.

  3. #3
    Caught the Bug tdans's Avatar
    Join Date
    Apr 2016
    Location
    Logan UT
    Posts
    55
    I know the oil pressure senders get clogged and stuck all the time. I would replace that before you get too crazy.


    Sent from my iPad using WAYALIFE mobile app

  4. #4
    Fresh Catch kbsvo2go's Avatar
    Join Date
    Apr 2014
    Location
    East Tennessee
    Posts
    24
    I had the same problem on my sons 02 TJ. I removed the sending unit and threaded in a direct direct reading gauge to verify if I actually had oil pressure. My pressure was good on the direct reading gauge. I replaced it with a aftermarket sending unit and the problem came back within a week. I bought a sending unit from the dealer and it's been good for over a year now.


    Sent from my iPad using WAYALIFE mobile app

  5. #5
    Fresh Catch Creekcrawler's Avatar
    Join Date
    Dec 2016
    Location
    US
    Posts
    4
    I appreciate everbodys response to my question. I had already bought an aftermarket sending unit and nothing changed. Im going to have to do some more checking though because I've been having a miss.
    Found today that I have very little compression on #5 cylinder.

    Sent from my SAMSUNG-SGH-I547 using WAYALIFE mobile app

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
About us
“wayoflife” is a moniker that I’ve been using for 20 years now and I chose it because I think it does a great job of explaining, in simple terms, the passion I have for Jeeps and the Jeep way of life. This is a lifestyle that transcends age, gender and race as the only thing you need to be a part of it is a love for the outdoors, a desire to explore, a yearning to take on a challenge and a will to conquer it. Over the years, Cindy and I have attempted to capture the essence of this lifestyle through photographs and videos and share it with others around the world. And, this is how WAYALIFE was born.
Join us
WATCH OUR VIDEOS