Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: 18 JLUR sway bar disconnect

  1. #1
    Caught the Bug BlueRubicon's Avatar
    Join Date
    Jan 2019
    Location
    Pa
    Posts
    75

    18 JLUR sway bar disconnect

    While off roading and doing some serious rock garden crawling, I was getting Shifter error's and Sway bar disconnect errors. This has not happened before. Shutting off vehicle corrected each time this happened, which was more than once.
    I just pressure washed the mud and rocks off, vacuumed inside then drove out to fill tank for the week. I remembered the events of the weekend and when I got back into driveway, put into 4L and attempted to disconnect sway bar. I can hear the subtle 'kink' which is sound it normally makes...but it says Connected. Tried this four or five times and each time the same. It is not Dis-connecting.
    I have no error message. Has this occurred to anyone here?

  2. #2
    Hooked Noble Woodsman's Avatar
    Join Date
    Jul 2019
    Location
    Houston, TX
    Posts
    130
    Quote Originally Posted by BlueRubicon View Post
    While off roading and doing some serious rock garden crawling, I was getting Shifter error's and Sway bar disconnect errors. This has not happened before. Shutting off vehicle corrected each time this happened, which was more than once.
    I just pressure washed the mud and rocks off, vacuumed inside then drove out to fill tank for the week. I remembered the events of the weekend and when I got back into driveway, put into 4L and attempted to disconnect sway bar. I can hear the subtle 'kink' which is sound it normally makes...but it says Connected. Tried this four or five times and each time the same. It is not Dis-connecting.
    I have no error message. Has this occurred to anyone here?
    Not sure about the JL setup, but i know the electric motors on JKUR setups often fail due to water or dirt ingress. Maybe that's what you're experiencing? Maybe try dismantling the motor to clean it. EVO sells a manual lever to replace the motor, in case you need to replace it and dont want to.


    Sent from my iPhone using WAYALIFE

  3. #3
    Caught the Bug BlueRubicon's Avatar
    Join Date
    Jan 2019
    Location
    Pa
    Posts
    75
    After actually taking a look at motor I saw it took a good hit. Wires on plug are intact, but insulation removed off of some of them.
    The integrity of electrical connection seems adequate so I hope it's not the motor. Guess I will have to take to dealer.

    SB disconnect.jpg
    SB plug.jpg

    Every time I post image one or all pics always upside down or sideways...forgive me.

  4. #4
    Caught the Bug BlueRubicon's Avatar
    Join Date
    Jan 2019
    Location
    Pa
    Posts
    75
    Unfortunately I noticed earlier in week that last weekend the disconnect motor took a hit, and the wires got frayed real close to connector. It is at dealer now and the connector needs to be replaced because there are no replacement pins for connector. On top of this, Mopar doesn’t sell just the connector, only harness which is $259. Lesson learned...I need to protect the motor with a plate.
    I asked dealer to try and test motor so I at least know if it works. $1800 for motor.
    Worst case motor bad, I am thinking about the anti lock swaybar on market. Anyone have one or seen someone using?

  5. #5
    Caught the Bug BlueRubicon's Avatar
    Join Date
    Jan 2019
    Location
    Pa
    Posts
    75
    I have since bought the EVO manual sway bar disconnect. It works great. Today I thought I would try and disassemble factory disconnect motor since dealer says it's bad and I have to pay to replace. Check out the photos and see if it makes you sick as me.
    Vehicle is less than a year old and less than 10,000 miles on it. Imagine what yours looks like if you have older and way more miles.
    I think it's pathetic that Jeep cannot make product which is not sealed for one thing. Also facing the plug up or towards the rear would be better than facing front.

    [/ATTACH]IMG_2131.jpgIMG_2132.jpgIMG_2133.jpgIMG_2134.jpgIMG_2135.jpgIMG_2136.jpg
    Attached Images Attached Images

  6. #6
    Addict wjtstudios's Avatar
    Join Date
    Nov 2016
    Location
    Rochester, MI.
    Posts
    6,086
    That’s crazy. Must have had a bad seal somewhere. Mines going on six years and has been submerged more times than I can count and still works as good as the first day. If and when it does fail, I’ll be going the EVO route though.


    2015 JKUR AEV JK350
    1985 CJ8 Scrambler
    2015 JKU Rubicon AEV JK350
    1985 Jeep CJ8 Scrambler

  7. #7
    Old Timer bkac's Avatar
    Join Date
    Dec 2012
    Location
    Center of Oregon
    Posts
    3,834

    18 JLUR sway bar disconnect

    I think I see the problem why it’s not working. Lol thanks for sharing


    Sent from my iPhone using WAYALIFE
    Not "living" but "loving" life always!

  8. #8
    Hooked Noble Woodsman's Avatar
    Join Date
    Jul 2019
    Location
    Houston, TX
    Posts
    130
    Why is this not covered under warranty? Sounds like the jeep is still very new.


    Sent from my iPhone using WAYALIFE

  9. #9
    Nothing but a Thing nbunga's Avatar
    Join Date
    May 2017
    Location
    Northeast Indiana
    Posts
    1,216
    Quote Originally Posted by Noble Woodsman View Post
    Why is this not covered under warranty? Sounds like the jeep is still very new.


    Sent from my iPhone using WAYALIFE
    I was wondering the same thing.

  10. #10
    Caught the Bug BlueRubicon's Avatar
    Join Date
    Jan 2019
    Location
    Pa
    Posts
    75
    Quote Originally Posted by nbunga View Post
    I was wondering the same thing.
    Because it has marks on it, they say it was damaged. My dealer sucks!! I don't have energy and patience to create a big stink. If I had contact to Mopar above dealers head, I would reach out to them. If someone here 'knows a guy'...message me please.

Page 1 of 2 12 LastLast

Similar Threads

  1. sway bar disconnect?
    By dunstan74 in forum Jeep JK Wrangler
    Replies: 18
    Last Post: 02-18-2014, 03:48 PM
  2. Rubi sway bar disconnect
    By DVS1 in forum Wanted (Active Members ONLY)
    Replies: 10
    Last Post: 11-14-2013, 01:39 PM
  3. Sway bar disconnect
    By Millerj87 in forum Jeep JK Wrangler
    Replies: 11
    Last Post: 07-04-2013, 01:43 AM
  4. Sway bar disconnect
    By Canvas JK in forum Jeep JK Wrangler
    Replies: 14
    Last Post: 05-13-2013, 11:03 PM
  5. Sway bar disconnect
    By Chairokey in forum General Jeep Stuff
    Replies: 7
    Last Post: 05-30-2012, 03:13 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
About us
“wayoflife” is a moniker that I’ve been using for 20 years now and I chose it because I think it does a great job of explaining, in simple terms, the passion I have for Jeeps and the Jeep way of life. This is a lifestyle that transcends age, gender and race as the only thing you need to be a part of it is a love for the outdoors, a desire to explore, a yearning to take on a challenge and a will to conquer it. Over the years, Cindy and I have attempted to capture the essence of this lifestyle through photographs and videos and share it with others around the world. And, this is how WAYALIFE was born.
Join us
WATCH OUR VIDEOS