6 new codes

desertrunner

Active Member
well my 2 door decided to pop on the CEL today and spit out 6 codes for me
P0591/579 - cruise control speed switch
P0128 - cooling system malfunction
B1630/162C - R/L low beam circuit high
B1634 - L high beam circuit high

A while back i had an issue with my horn staying on constant and for the time being i just pulled the fuses and never got around looking into it, but now today the cruise control stopped working so looks like i might have a potential clock spring replacement in my future, i imagine they are related.

The cooling system one seems odd but its just about 60K miles and is probably due for a coolant flush and maybe a thermostat replacement

For the headlights i had an issue with my left hi beam going out the other day but i unplugged and re plugged in the KC grav pros and it came back on like normal. I just chocked it up to the connector being loose guess ill have to check them again.

Anyone else had any of these codes and tips on what to try first?
 

desertrunner

Active Member
well i unplugged and re plugged in my headlights, did a battery reset, cleared the codes with my flashcal and took the jeep for a drive. No more CEL, cruise control works and i got it well up to temp and it didn't throw the cooling system code again. Thought i would try my luck with the horn again and no such luck, as soon as the fuses went back in the horn was constant on so out those went again. My coolant level is a little low but i do need to change it anyways. IDK ill just chock it up to what ever is messing with my horn is probably the culprit but at least i have cruise control again... for now
 

Jsouder53

Active Member
I just had the P0128 pop up today. Did you have any luck figuring out what that could be? I think the low beam circuits are due to the LED head lights. I have similar codes that came up after I installed them.
 

WJCO

Meme King
I just had the P0128 pop up today. Did you have any luck figuring out what that could be? I think the low beam circuits are due to the LED head lights. I have similar codes that came up after I installed them.
P0128 is almost always a thermostat starting to stick on various vehicles. An easy check is a 20 dollar infrared temp laser from Home Cheapo and you can check each side of the thermostat to see if it's working correctly. I change thermostats between 30k and 50k anyways just for preventative maintenance.
 

Jsouder53

Active Member
P0128 is almost always a thermostat starting to stick on various vehicles. An easy check is a 20 dollar infrared temp laser from Home Cheapo and you can check each side of the thermostat to see if it's working correctly. I change thermostats between 30k and 50k anyways just for preventative maintenance.
I was actually just reading another post of yours stating the infrared gun on another thread. I’m wondering if it came up today since it’s the first cold day and the engine was colder than normal?

My Jeep is getting close to 90k so it sounds like a common problem anyways.
 

WJCO

Meme King
I was actually just reading another post of yours stating the infrared gun on another thread. I’m wondering if it came up today since it’s the first cold day and the engine was colder than normal?

My Jeep is getting close to 90k so it sounds like a common problem anyways.
Usually a 128 sets when the thermostat is stuck open. Stuck open is way better than stuck closed but if it's stuck open, it will take longer for heater to work and/or sensors to go into closed loop so it can trigger other issues regarding engine performance. It's an easy check but also an easy PM part to just replace IMO.
 

Jsouder53

Active Member
Usually a 128 sets when the thermostat is stuck open. Stuck open is way better than stuck closed but if it's stuck open, it will take longer for heater to work and/or sensors to go into closed loop so it can trigger other issues regarding engine performance. It's an easy check but also an easy PM part to just replace IMO.
I will replace it soon, I appreciate your input.
 

desertrunner

Active Member
yeah so after I reset the codes the CEL went out and stayed off for a few weeks. I came back on yesterday with the thermostat code. Honestly after replacing the radiator on the 4 door and now looks like soon for the second time I didn't want to deal with coolant on the 2dr so its going to the dealership on Friday for a coolant flush and fill, thermostat replacement, AND finally the airbag recall haha.
I'm not surprised though the coolant is 9 years old and 59K miles on it, it need to be replaced a while ago but I got lazy. And the classic stuck open thermostat symptoms are there funny to see the temp gauge sitting low.
 

desertrunner

Active Member
Picked up the jeep from the dealership. They did a coolant flush and fill and tstat replacement seems to have fixed the CEL. Pretty sure it was stuck open easy fix there. While it was there I had them look at the horn and looks like there was a star case on the cruise control switch and they ordered parts to replace. That should take care of all the codes I care about haha 20211015_173651.jpg
 

jeeeep

Active Member
my cruise control error codes P0591/579 was intermittent for a long time but eventually other codes started popping up which were all cleared with recalled clock spring service
 

desertrunner

Active Member
my cruise control error codes P0591/579 was intermittent for a long time but eventually other codes started popping up which were all cleared with recalled clock spring service
I mentioned the clock spring too they ended up diagnosing as the cruse control switch. Which my Googling seemed to be 50/50 and that the horn specifically was more often the cruise switch. So idk hopefully that fixes it, if not clock spring I'm sure is next
 
Top Bottom