Page 1 of 2 12 LastLast
Results 1 to 10 of 18

Thread: Emergency help

  1. #1
    Fresh Catch
    Join Date
    May 2018
    Location
    Idaho
    Posts
    9

    Emergency help

    I have a 2012 wrangler unlimited sport in right hand drive(bone stock) that I use for mail delivery. Yesterday was my first day using it on the route and it went into full limp mode. It had been toying with me for a while before this and being new to Jeeps I figured it was in eco mode or something. At first it would cap my rpms at 2500 in 3rd gear and on(pretty much after getting to highway speed) but it I really have it gas it would go higher. Now, full limp mode. First wonít go past 3k and every other gear stops at 2.5k rpms even with my foot to the floor.
    In park it wonít go past 3.5k.
    No dealerships are open where I live today and Iím on the route again tomorrow! Iím panicking at the moment. Iíve been reading for hours and the only thing Iíve learned is that it could be anything. I checked and the camshaft position sensor looks like itís been replaced recently. Itís thrown a bunch of codes when looked up all point to that sensor. Other than that I have no idea please help!

  2. #2
    Administrator wayoflife's Avatar
    Join Date
    Oct 2011
    Location
    Carson City, NV
    Posts
    53,714
    Is your Jeep stock or is it running bigger tires or different gears? Are you getting lights on your dash like ABS, ESP or other wise?

  3. #3
    Fresh Catch
    Join Date
    May 2018
    Location
    Idaho
    Posts
    9
    Bone stock, Iím getting the oil light and traction control light. Also have the GASCAP sign over the odometer but upon inspection it looks like that was from a hanging hose connecting to the evap. Also would take about 4 seconds of cranking for it to start all yesterday. Started it and drove it to the gas station this morning and it started fine. Everything was fine till I tried to get on it a little bit. Did a very hard shift at 3500 rpms and then back to limp mode

  4. #4
    Administrator wayoflife's Avatar
    Join Date
    Oct 2011
    Location
    Carson City, NV
    Posts
    53,714
    Okay, the traction control light could point to your problem being a bad speed sensor, one that has a loose or chaffed wire or one that is unplugged. The hard start and hard shift could point to it being a camshaft position sensor. Being that you said you got a code for that, it's more than likely your problem.

  5. #5
    Nothing but a Thing Snboarder113's Avatar
    Join Date
    Oct 2015
    Location
    michigan
    Posts
    1,624
    What codes come back after being cleared? Also completely off topic but does it feel just weird as shit driving on the other side of the car?


    Sent from my iPhone using WAYALIFE mobile app

  6. #6
    Nothing but a Thing Zstairlessone's Avatar
    Join Date
    Dec 2012
    Location
    Texas
    Posts
    1,064
    ...and disconnect the battery for about 15 minutes, itís worth a try


    Sent from my iPhone using WAYALIFE mobile app

  7. #7
    Fresh Catch
    Join Date
    May 2018
    Location
    Idaho
    Posts
    9
    So update. I had the negative terminal off for about 45 minutes. Seemed to clear all the codes and everything was fine. About 10 minutes of driving to the auto parts store and back and the oil light and traction control light came back on, aaand back into limp mode.
    The camshaft position sensor looks pretty damn new which makes me wonder, because yeah all the codes point to that. Might not have anything to do with it but if it helps the Jeep warms up insanely fast. 2 minutes of idle and itíll be all the way warmed up

  8. #8
    Fresh Catch
    Join Date
    May 2018
    Location
    Idaho
    Posts
    9
    Also, I have no idea what wire it is or what itís for but there is a hanging one. Iíll get a picture shortly

  9. #9
    Fresh Catch
    Join Date
    May 2018
    Location
    Idaho
    Posts
    9
    Here are some pictures
    Attached Images Attached Images

  10. #10
    Knows a Thing or Two Samuelh3's Avatar
    Join Date
    Apr 2017
    Location
    Southern California
    Posts
    756
    Oil level?


    Sent from my iPhone using WAYALIFE mobile app

Page 1 of 2 12 LastLast

Similar Threads

  1. Emergency brakes
    By Clark Collins in forum For Sale
    Replies: 0
    Last Post: 12-17-2014, 11:15 PM
  2. Emergency Assistance ?!?
    By Stalter08Rubi in forum Jeep JK Wrangler
    Replies: 20
    Last Post: 11-06-2014, 08:37 PM
  3. Pavement Ends Emergency Top for JKU
    By DBTJKU in forum For Sale
    Replies: 4
    Last Post: 03-29-2014, 10:02 PM
  4. Pavement Ends Emergency Top
    By Hack12 in forum For Sale
    Replies: 0
    Last Post: 08-09-2013, 07:31 PM
  5. Best top trail/emergency cover
    By rinkishjk in forum General Jeep Stuff
    Replies: 1
    Last Post: 03-22-2013, 07:39 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
About us
ďwayoflifeĒ is a moniker that Iíve been using for 20 years now and I chose it because I think it does a great job of explaining, in simple terms, the passion I have for Jeeps and the Jeep way of life. This is a lifestyle that transcends age, gender and race as the only thing you need to be a part of it is a love for the outdoors, a desire to explore, a yearning to take on a challenge and a will to conquer it. Over the years, Cindy and I have attempted to capture the essence of this lifestyle through photographs and videos and share it with others around the world. And, this is how WAYALIFE was born.
Join us
WATCH OUR VIDEOS