3.6 Passenger Side Oil Leak?

FFPulley77

Hooked
I’ve been intermittently smelling a small whiff of burning oil for about 3 months now. It’s weird, I went on a 1,400 mile round trip and never smelled it. But if I drive across town I’ll smell it occasionally. Finally decided to climb underneath it to day and here is what I found

First picture is from underneath, this is the passenger side between the transmission and exhaust. There’s a small drop of oil. B3144A75-8F0C-4346-8AAD-0B89BFDBADE7.jpeg
This picture is topside looking back toward the firewall. You can see there’s some build up.
6274AC33-5200-4BA3-B681-A53E95989CF2.jpeg
I think it’s the valve cover gasket, but I’m not sure. Has anybody else ever had this?
Also, this is on a 2013 with about 124,000 miles.
 

WJCO

Meme King
Shine a light down by your oil filter and see if there's oil pooling in the intake valley. Oil filter housing is a common leak on these
 

FFPulley77

Hooked
Shine a light down by your oil filter and see if there's oil pooling in the intake valley. Oil filter housing is a common leak on these
50A18078-B64A-4DD8-8408-871E55C16D30.jpeg
Couldn’t really get good pictures, but from there all the way back as far as I could see, it was dry.
 

ScottofKSU

Member
I agree on checking out the valve cover gasket... Perhaps yours was one of the early 2013 models that had the head casting sand issue resulting in the replacement of the head thus damaging the gasket or perhaps not fully torquing one of the fasteners when they reinstalled the valve cover.
 

AgBass01

Member
Did you find a solution to this? I have burning oil smell as well, '12 with 140k miles. Oil cooler has already been replaced within the last year so wondering if it's head gasket myself.
 

FFPulley77

Hooked
Did you find a solution to this? I have burning oil smell as well, '12 with 140k miles. Oil cooler has already been replaced within the last year so wondering if it's head gasket myself.
Yep, I had a leaking valve cover gasket on the passenger side near the back. Local Jeep shop changed both sides and it solved the issue.
 
Top Bottom