Gear swap and programming with SC Flashpaq

USMC Wrangler

New member
One of the biggest surprises of the day was after the gear swap. I started driving down the road and something didn’t feel right. I tried to manually shift my auto (‘13 JKUS) and nothing changed. I had programmed 4.56 in with my Flashpaq before I drove an inch. I had read of that issue of limp mode if it’s driven BEFORE programming.

I went back to my buddies and told them what was going on. Then I remembered counting the teeth on both ring and pinion gears to confirm a match. The rings had 41 teeth and the pinions 9. Dividing the two works out to 4.555555555555556. Again, I plugged 4.56 in the axle ratio change initially. I got the DTC of P0731 Gear 1 Incorrect Ratio.

The fix? Program in 4.55 instead of 4.56!

Maybe this has been covered here, but I couldn’t find it. I’m no engineer but it’s crazy to me that .01 difference could cause this. I also realize 4.88 is probably more common of a ratio. I do have to wonder if anyone else has experienced this and had to do something similar?

Overall "build thread"

DIY trail/tube door build
Last edited:

USMC Wrangler

New member
Here’s an update from my own trial and error.

I just reinstalled the 87 octane tune from the Flashpaq. When it was done I went for a test drive. It went back to the limp mode feeling and 1st gear error DTC. Limped home and plugged in again. Updated the gear ratio from 4.55 to 4.56 and it worked this time. Other than reinstalling the tune I can’t think of any reason why it would’ve done this. Well, except... Superchips! I truly have a love/hate relationship with this tool. I love it when it programs correctly and I hate it for all the work arounds and inconsistency it’s displayed.
Top Bottom