OEM Aux wiring - Check engine with start stop disabled

So here is the thing, I thought I had done my research and figured OEM was not a bad way to go. I mean what could go wrong?

Well, the pass through the firewall shit....I made sure to keep away from the main wiring harness and I feel pretty confident that it is fine. The pin connector operation was not a fun pull but I did work it out in the end and it was all buttoned up.

Turn on the ignition and it works just fine. Next thing I know, I get a check engine with the start/stop not ready alert. I did not get a turn off vehicle or limp mode issue and I drove it a few miles with no issues. Its practically new so I went and did some more research and found that the issue was the Fuse Array. Apparently, I had too much fun with the sauce and somehow ended up tripping up one of those little suckers in the fuse array so I ordered a new one.

Got it today and installed. It was a mild pain but it pretty much went on fine. Turned on the truck, all good. No lights.

Drove it around the block and parked it. Kept it on since I was curious and a minute later, lights went off on the display. Turned it off and back on and I am back to the check engine light on and the auto on/off light as well.

Any suggestions?

Here is a solid question too: the instructions also mention to take it into the dealer for them to flash. No biggie, I knew that....what surprised me is that the switches don't light up at all regardless. I figured they would considering the flash (in my mind) was only to place it on your radio as an available setting.

PS. Im ready for the beat down. I didnt go another route because I dont plan on adding a ton of lights or go crazy and 4 switches seemed like just enough. :)
Think I just found my answer. The orange canbus wires connector is a piece of garbage and I need to splice those together instead of using the garbage connector from Mopar. I am pretty sure this is the issue now. Makes perfect sense.


Caught the Bug
Did you program it ? You have to use a Tazer (I think Jscan can enable it to) - if you haven't done so that would be why.


Caught the Bug
I have a Tazer that came with an AEV lift. Wonder if that would work. I'll give it a try with it and let you know.
Yup a tazer should work, i think AEV's programmer would work to. I'd try that before I'd mess with any wiring (if you already did that per the instructions) - you have to program the BCM to accept/look for it otherwise its not going to even turn on.


Guy with a Red 2-Door
Just make sure that orange wire is on the same side of the connector. If in opposite pins then that will happen. Did that on my friends Jeep when installing his aux switches by accident.

Also the tazer will allow you to add the add switch feature to your Jeep.
Follow up on this. Added the tazer, AEV's programmer did not have the Aux panel available so I had to purchase a new one. Set up the tazer, cleared the code, and it seemed to have worked. After I cleaned up the little mess the install had made, I drove around the block and the check engine light came back on and the auto start/stop alert happened again.

I was avoiding having to reopen the panel to access the wires but I had a strong feeling that connection was the real cause. Went in on the wiring, found my dried up blood from a mysterious cut I had suffered the last time I messed around down there, and was able to determine that the connector provided with the kit just barely held the pin connectors in place. Cut off both ends and placed them into a crimping connector, turned on the Jeep.......................and it worked!! Cleared the code, did the reboot, and called it a day.

Happy it's done. I have no fears of working on any vehicle or getting into it with wires but I think everyone truly has some sense of satisfaction when shit works the way its supposed to.
Top Bottom