Possible radiator leak??

Lojo

New member
I have a 2017 JKU with 24k on it currently. Got in it yesterday and noticed a coolant smell. I checked passenger floor board area and it’s dry. I was in a drive through this evening and noticed slight evaporation/steam coming from the front. Upon closer inspection with a flashlight and engine running I think it is coming from passenger top radiator area. Does anyone have any experience with similar situations?? It is under warranty so going to take it in Monday, just wondering if anyone has any input I may be missing. Thanks


Sent from my iPhone using WAYALIFE mobile app
 

Lojo

New member
So took Jeep into dealer and pressure tested. They could not find the leak. There is a distinct coolant smell inside the cab. Has anyone ever experienced a similar situation?? Thanks all


Sent from my iPhone using WAYALIFE mobile app
 

Nespoli1

New member
So I had same issue. Under hood there is 4 plastic pins on top holding plastic cover. Pop pins and look down right side of radiator. See if you see dried pink residue anywhere. Its probably evaporating. The JKs factory radiator is junk. I had to show the dealer where the leak was after they said it wasn’t leaking.


Sent from my iPhone using WAYALIFE mobile app
 

Lojo

New member
Thanks... I will check in the morning!! I do think it is evaporating because there is some coolant loss. I have refilled marked the level to monitor and see where it goes from there.


Sent from my iPhone using WAYALIFE mobile app
 

jeeeep

Active Member
if you're smelling it on the inside, could be the heater core and it'll take a while for it to show up inside the cab. oull back the passenger side carpet at the center and check for stains.

The other common area is along the bottom of the radiator behind he plastic shrouding on the back side, hard to see but use a good light and pull the plastic cover back.

If you have a black light, the fluid will glow
 

JoeB-JKURX

New member
Frequently, the plastic thermostat housing will have a hairline crack that the dealer mechanics often don't find when you take it in on warranty. A replacement is pretty cheap and not too hard to install.
 

sipafz

Caught the Bug
So I had same issue. Under hood there is 4 plastic pins on top holding plastic cover. Pop pins and look down right side of radiator. See if you see dried pink residue anywhere. Its probably evaporating. The JKs factory radiator is junk. I had to show the dealer where the leak was after they said it wasn’t leaking.


Sent from my iPhone using WAYALIFE mobile app

Thanks... I will check in the morning!! I do think it is evaporating because there is some coolant loss. I have refilled marked the level to monitor and see where it goes from there.


Sent from my iPhone using WAYALIFE mobile app

I had the exact same thing as Nespoli described:

IMG_8409.JPG

2016 / 30k

I could smell coolant in the cab at times, but more often I would see wisps of steam from under the hood.

I took it to the dealership and asked if they would like to see a picture of where it’s leaking from. They said that they would find the leak if there was one. I got a call a few hours later, that it passed the “pressure check” and that I could pick it up. I had to text the service writer this picture and demand that they fix the issue. Unfortunately, my dealership kind of sucks and has to be spoon fed.

Good luck with yours!
 
Last edited:
I had the same issue as OP, could smell a faint smell of coolant now and then when walking away from my Jeep.

Agreed with others if you can smell it....its leaking.

I finally found the smoking gun bottom of the rad, driver side on the plastic end cap....coolant residue. Snap a few pictures off to the dealer.

2016 with at 59,800KM (200km left of full warranty) showed my pictures, two hours later new rad fully coverage on warranty.

I've since put 20,000KM on the Jeep....not once have I smelt coolant.

Good luck...
 

Lojo

New member
Thanks for all the insights!! Getting ready to look into now with my 1000 lumen light so hopefully I find it. I’ll keep ya posted. Thanks again


Sent from my iPhone using WAYALIFE mobile app
 

Lojo

New member
Well I am officially UTL!!! Under carpet, behind console, radiator nada!!! Just going to have to wait till it shows and keep taking it in. FML!! Lol


Sent from my iPhone using WAYALIFE mobile app
 

jdofmemi

Active Member
Looks like I get to play with this as well.

2015 with just over 40,000 miles

I've been smelling it for a while. Today I got a picture of the drip, well, the bottom where it runs to to drip anyway.

Are any of the replacement radiators better than OEM?
 

Attachments

  • IMG_20190303_142443-1008x756.jpg
    IMG_20190303_142443-1008x756.jpg
    132.3 KB · Views: 73

Bear_JT

Active Member
Well I am officially UTL!!! Under carpet, behind console, radiator nada!!! Just going to have to wait till it shows and keep taking it in. FML!! Lol


Sent from my iPhone using WAYALIFE mobile app

Pop off the plastic engine cover on top of the engine. Use your flash light to look down around where your oil filter housing is. Look down into the engine valley and see if you see any coolant pooling in there.


Sent from my iPhone using WAYALIFE mobile app
 

BaddestCross

Active Member
Looks like I get to play with this as well.

2015 with just over 40,000 miles

I've been smelling it for a while. Today I got a picture of the drip, well, the bottom where it runs to to drip anyway.

Are any of the replacement radiators better than OEM?
From what research I've done, no. All the high end ones seem to have issues and blow out quick for some reason.

--
Build Thread - Adventures of Fiona - https://wayalife.com/showthread.php?t=47407
 

black pearl

Active Member
Looks like I get to play with this as well.

2015 with just over 40,000 miles

I've been smelling it for a while. Today I got a picture of the drip, well, the bottom where it runs to to drip anyway.

Are any of the replacement radiators better than OEM?

I ended up getting one for $100 as it seams they all have some kind of issues. It was a OEM knock off. Been in for six months now.


Sent from my iPhone using WAYALIFE mobile app
 

Wethy

Member
Mine leaked from the top of the drivers side. I replaced it with the spectra about 6 months ago. From my understanding and what ive read, thats the typical place that most jk rads leak.

Screenshot_20190304-094421_Gallery.jpg

Sent from my SM-G960W using WAYALIFE mobile app
 
Top Bottom